6135 links
  • GuiGui's Show
  • Home
  • Login
  • RSS Feed
  • ATOM Feed
  • Tag cloud
  • Picture wall
  • Daily
Links per page: 20 50 100
 
  • Quelques points de détails sur DNS
    Parfois, on me demande des détails précis sur DNS tout en me demandant la section du RFC kivabien pour argumenter. Cette fois-ci, je me mets ça de côté.

        * Un CNAME dans un domaine A peut pointer sur un label dans un domaine B. C'est l'un des buts de ce RRTYPE, tout comme DNAME pour un sous-arbre. Source : RFC 2181, section 10.1 - « The DNS CNAME ("canonical name") record exists to provide the canonical name associated with an alias name.  There may be only one such canonical name for any one alias. That name should generally be a name that exists elsewhere in the DNS, though there are some rare applications for aliases with the accompanying canonical name undefined in the DNS »

        * Oui, il n'est pas conseillé (mais pas interdit) de chaîner les CNAME. Source : RFC 1034, section 5.2.2 - « Multiple levels of aliases should be avoided due to their lack of efficiency, but should not be signalled as an error. Alias loops and aliases which point to non-existent names should be caught and an error condition passed back to the client. »

        * Il est interdit de mettre un alias comme valeur d'un enregistrement de type MX ou NS. Source : RFC 2181, section 10.3 - « The domain name used as the value of a NS resource record, or part of the value of a MX resource record must not be an alias.  Not only is the specification clear on this point, but using an alias in either of these positions neither works as well as might be hoped, nor well fulfills the ambition that may have led to this approach. »

        * Pareil pour le RRTYPE SRV. Source : RFC 2782, - « The domain name of the target host.  There MUST be one or more address records for this name, the name MUST NOT be an alias (in the sense of RFC 1034 or RFC 2181). »

        * Il faut au moins 2 serveurs qui font autorité par zone même si c'est pas « MUST » mais « require ». RFC 2182, section 4.3.5 - « The DNS specification and domain name registration rules require at least two servers for every zone.  That is, usually, the primary and one secondary. [...] It is recommended that three servers be provided for most organisation level zones, with at least one which must be well removed from the others. »

        * Un paquet DNS n'est pas limité à 512 octets sur UDP. C'est tout l'intérêt de edns(0) normalisé en  1999. Source : RFC 2671, section 2.3 - « DNS Messages are limited to 512 octets in size when sent over UDP. While the minimum maximum reassembly buffer size still allows a limit of 512 octets of UDP payload, most of the hosts now connected to the Internet are able to reassemble larger datagrams. Some mechanism must be created to allow requestors to advertise larger buffer sizes to responders. »
    February 28, 2015 at 2:55:29 AM UTC - permalink - http://shaarli.guiguishow.info/?D_KSww
Links per page: 20 50 100
 
Mentions légales identiques à celles de mon blog | CC BY-SA 3.0

Shaarli - The personal, minimalist, super fast, database-free, bookmarking service by the Shaarli community